PI Software - Cognitive Assessment is Non-Responsive
Incident Report for The Predictive Index
Resolved
We have released a fix for this issue, and are monitoring the results system-wide. Please refresh your browser, and if you continue to experience this issue, please contact customerservice@predictiveindex.com. We’ll be sure to investigate right away.
Posted Sep 23, 2021 - 12:46 EDT
Update
We are continuing to investigate this issue.
Posted Sep 23, 2021 - 12:44 EDT
Investigating
We're investigating an issue related to assessment takers inability to initiate the Cognitive Assessment. Affected users will encounter the browser spinning and eventually error out. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Sep 23, 2021 - 11:31 EDT
This incident affected: PI Software: Core Platform, PI Software: Assessment Site, and API - Application Integrations.