PI Software: Degraded Performance Across Software
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that this issue has been resolved. Thank you for your patience while we worked through this issue. If you continue to encounter it, please let us know at customerservice@predictiveindex.com.
Posted Jun 14, 2022 - 16:19 EDT
Monitoring
At this time, services to software should be stable. Our engineering team has confirmed the issue and are currently monitoring progress. Thank you for your patience.
Posted Jun 14, 2022 - 15:42 EDT
Update
We are continuing to investigate this issue.
Posted Jun 14, 2022 - 15:02 EDT
Investigating
Our engineering team is currently investigating an incident with degraded performance across the majority of our modules. Affected users may be unable to navigate to the modules and experience longer than usual load times which may result in error messages. We’ll post updates as we have them. Thank you for your patience.
Posted Jun 14, 2022 - 15:02 EDT
This incident affected: PI Software: Core Platform.