Regional Comcast Connectivity Issues When Accessing PI Websites
Incident Report for The Predictive Index
Resolved
The incident involving an internet provider, Comcast, has been resolved. If you or a partner/client have Comcast as your internet provider, you should now be able to access the main PI website (www.predictiveindex.com) or the PI Software (app.predictiveindex.com) as their DNS servers are responding properly again.
Posted Mar 17, 2021 - 12:25 EDT
Investigating
An incident involving an internet provider, Comcast, has been identified. If you or someone else has Comcast as your internet provider, you may be unable to access the main PI website (www.predictiveindex.com), the PI Software (app.predictiveindex.com) or any other predictiveindex.com domina or subdomain as Comcast's DNS servers are not responding properly. We will continue to monitor the situation as it evolves.
Posted Mar 17, 2021 - 11:30 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.