Cognitive Assessment Link Unavailable
Incident Report for The Predictive Index
Resolved
We have identified and resolved the issue. Cognitive Assessment links should now navigate properly to the assessment.
Posted Jul 17, 2024 - 16:15 EDT
Investigating
We are currently aware and investigating an issue where assessment takers are not able to properly navigate to the Cognitive Assessment when clicking on the invitation link.
Our engineering team is working a deploying a fix and the status page will be updated accordingly.
Posted Jul 17, 2024 - 15:35 EDT
This incident affected: PI Software: Assessment Site.