Outage
Incident Report for The Predictive Index
Postmortem

The root cause of the incident yesterday appears to have been due to a bad API service that had issues with thread pooling. In response to this, we expanded our number of instances and increased the thread pool on all the instances which resolved the issue.

Thanks so much for your understanding and patience during the incident yesterday!

Posted Oct 28, 2020 - 11:15 EDT

Resolved
We’ve confirmed that this issue has been resolved. Thank you for your patience while we worked through this issue., If you continue to encounter it, please let us know at customerservice@predictiveindex.com. A Postmortem will be shared within five business days of issue closure.
Posted Oct 27, 2020 - 11:35 EDT
Investigating
We're investigating an issue related to the dashboard page not loading when you log into the PI software, Invitation links, and assessments not loading. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Oct 27, 2020 - 10:22 EDT
This incident affected: PI Software: Core Platform, PI Software: Assessment Site, API - Application Integrations, and Connect Legacy Integrations.