PI Software - User Login
Incident Report for The Predictive Index
Resolved
This issue has been fully resolved. Thank you for your patience and understanding.
Posted Nov 04, 2021 - 18:15 EDT
Update
We are continuing to monitor for any further issues.
Posted Nov 04, 2021 - 16:13 EDT
Monitoring
We experience a brief issue with users accessing the software which has been resolved. We will continue to monitor the systems. Thank you for your patience while we worked through this issue. If you continue to encounter it, please let us know at customerservice@predictiveindex.com.
Posted Nov 04, 2021 - 13:52 EDT
This incident affected: PI Software: Core Platform.