Completed Behavioral Assessments not Showing in Software Accounts
Incident Report for The Predictive Index
Resolved
Our engineering team has identified the root cause with behavioral assessments not showing up in client accounts and we’ve confirmed that this issue has been resolved. No data has been lost and all assessments recently taken wil show up in client accounts shortly. Thank you for your patience while we worked through this issue. If you continue to encounter it, please let us know at customerservice@predictiveindex.com. A Postmortem will be shared within five business days of issue closure.
Posted Apr 25, 2022 - 10:22 EDT
Investigating
We're currently investigating an issue related to recently completed behavioral assessments not showing up in software accounts. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Apr 25, 2022 - 09:28 EDT
This incident affected: PI Software: Assessment Site.