PI Software: Users Unable to Log in or Navigate Software
Incident Report for The Predictive Index
Resolved
This incident has been declared as resolved.
Posted Sep 07, 2022 - 17:05 EDT
Monitoring
The current status with Microsoft Azure's services has seemed to have stabilized and the issues with the PI Software and Assessment website appear to be resolved. We're currently monitoring for any additional changes.
Posted Sep 07, 2022 - 16:14 EDT
Identified
Microsoft is experiencing an unprecedented outage of its Azure data centers. These data centers host approximately 25% of all internet business applications, including The Predictive Index.

We’re uncertain how long Microsoft data centers will be down, but will continue to monitor for changes and provide updates.
Posted Sep 07, 2022 - 13:09 EDT
Investigating
We are currently experiencing degraded performance of our software affecting the ability for users to log in. Those who are logged may have trouble navigating the software. Assessment takers may experience errors while trying to access the Assessment website. Our Engineering team is aware and we are currently investigating a fix.
Posted Sep 07, 2022 - 12:53 EDT
This incident affected: PI Software: Core Platform.