Intermittent Slowness on Loading Pages in the Software
Incident Report for The Predictive Index
Resolved
The incident affecting our sub-processor has been resolved and platform is back to full functionality with no issues. If you run into any further problems, please contact us at customerservice@predictiveindex.com
Posted Jul 07, 2022 - 08:37 EDT
Identified
We are currently experiencing degraded performance of our software due to an outage that one of our sub-processors is working through. Users may notice pages not loading correctly, pages loading slowly, or they may receive 'Uh-oh' errors when taking actions within the software. Our engineering team is monitoring the status of the sub-processor outage and we will provide an update here once it has been resolved on their end.
Posted Jul 06, 2022 - 15:50 EDT
This incident affected: PI Software: Core Platform.