Degraded performance in the PI software

Incident Report for The Predictive Index

Resolved

We can confirm that the issue has been resolved. If you are still experiencing issues, please reach out to us via our support form.
Posted Oct 10, 2025 - 09:18 EDT

Investigating

There has been reports of degraded performance and inaccessibility within the PI software and Assessment sites. We’re currently investigating this issue and will post updates as soon as they are available.
Posted Oct 09, 2025 - 16:19 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.