PI Software: Issues with links in completion emails to administrators
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that the issue with the links in assessment completion emails to administrators has been resolved. If you experience any issues with links from completion emails sent after resolution, please let us know at customerservice@predictiveindex.com.
Posted Jun 15, 2023 - 14:18 EDT
Investigating
Our engineering team is currently investigating an issue with the links in assessment completion emails to administrators not being accessible. As a workaround in the meantime, you can navigate directly to the software to access the completed results. We will post updates once they are available. Thank you for your patience!
Posted Jun 15, 2023 - 13:53 EDT
This incident affected: PI Software: Assessment Site.