Degraded PI Software Performance
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that this issue is now resolved. Thank you for your patience during our work on this.

If you continue to encounter problems logging on to the software or accessing modules, please let us know at customerservice@predictiveindex.com
Posted Feb 02, 2022 - 19:26 EST
Monitoring
Our engineering team has implemented a fix that has brought our core platform, modules, and assessment site back up to full availability.

We will continue to monitor the situation and will set this incident to resolved after a period of time.
Posted Feb 02, 2022 - 18:36 EST
Identified
We are currently investigating an incident that is affecting all PI services. This includes all of our software modules as well as our assessment site, which are currently experiencing downgraded performance. The engineering team has identified the issue and working to fix it.

We will provide further updates here as we work to bring our services back online.
Posted Feb 02, 2022 - 18:32 EST
This incident affected: PI Software: Core Platform, PI Software: Assessment Site, and API - Application Integrations.