New User Creation Failing
Incident Report for The Predictive Index
Resolved
We’ve confirmed that this issue has been resolved. Users created today who have not received their welcome emails will receive them within the next 45 minutes or so. Thank you for your patience while we worked through this. Should this problem come up again moving forward, please let us know at customerservice@predictiveindex.com. A Postmortem will be shared here by end of day tomorrow.
Posted Oct 01, 2020 - 15:17 EDT
Monitoring
We’ve identified the root cause of this issue, and have deployed a fix which we are currently monitoring. We can confirm that new users created during this incident will not need to be re-created and should receive their welcome emails within the next hour.
Posted Oct 01, 2020 - 14:55 EDT
Investigating
We're currently investigating an issue related to new user creation within the PI software that was caused by a recent software release deployed around 8:30AM EST this morning. New users created around or after that time will be unable to login due to a failure in the user authentication process. Account admins and owners may also receive emails stating that user creation has failed for individuals. At this time we do not anticipate that any data or user records will be lost.

We will provide updates every hour until resolution and appreciate your patience while we work on this.
Posted Oct 01, 2020 - 14:36 EDT
This incident affected: PI Software: Core Platform and Auth0 Authentication API.