Resolved PI Software: Blank white screen when logging in

Incident Report for The Predictive Index

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 08:57 EDT

Update

We can confirm that the issue has been resolved. If you are still experiencing issues, please reach out to us via our support form.
Posted Jul 29, 2025 - 08:57 EDT

Update

A mitigation has been applied to alleviate the immediate issue; and the system is operational. We will continue to monitor and collaborate with the provider to ensure the issue is fully addressed.
Posted Jul 28, 2025 - 18:07 EDT

Update

Investigation is ongoing, and we are working to identify mitigations for what we suspect is a provider-related issue.
Posted Jul 28, 2025 - 17:11 EDT

Monitoring

We have reports of degraded performance during assessments and instances of users encountering a blank white screen within the PI software. These issues seem to be related to an outage with one of our service providers, which is currently impacting system performance and accessibility. Our engineering team is closely monitoring the situation and working to mitigate any disruptions as quickly as possible.
Posted Jul 28, 2025 - 15:25 EDT

Investigating

PI has been made aware users are experiencing a blank white screen when accessing the PI software. Our engineering team is aware and are currently investigating the issue.
Posted Jul 28, 2025 - 14:16 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.