Unable to Create Employee Experience Surveys
Incident Report for The Predictive Index
Resolved
We’ve confirmed that this issue regarding the creation of Employee Experience Surveys has been resolved. Thank you for your patience while we worked through this issue., If you continue to encounter it, please let us know at customerservice@predictiveindex.com.
Posted Jul 22, 2023 - 09:11 EDT
Investigating
Incident open/investigating (PI Software):
We're investigating an issue related to the creation of new Employee Experience Surveys in the PI software. Our team is currently investigating the issue. We’ll post updates as we have them. Thank you for your patience..
Posted Jul 21, 2023 - 12:23 EDT
This incident affected: PI Software: Core Platform.