Completing BA/CA Assessments
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that this issue is now resolved. Thank you for your patience during our work on this.

If you continue to encounter problems logging on to the software or accessing modules, please let us know at customerservice@predictiveindex.com
Posted Feb 24, 2022 - 09:06 EST
Monitoring
Our engineering team has implemented a fix so that emails are now being sent after completion of the behavioral and cognitive assessment and Report Kits.

We will continue to monitor the situation and will set this incident to resolved after a period of time.
Posted Feb 23, 2022 - 22:12 EST
Identified
We have identified the issue relating to the assessment takers for the cognitive and behavioral assessment not receiving a completion email and Report Kits not sending via email and are working to resolve the issue.
Posted Feb 23, 2022 - 22:00 EST
Update
We are investigating an issue relating to the assessment takers for the cognitive and behavioral assessment not receiving a completion email. This incident is also affecting ability to send a Report Kit. We’ll post updates as soon as they occur. Thank you for your patience, and we apologize for the inconvenience.
Posted Feb 23, 2022 - 20:21 EST
Investigating
We are investigating an issue relating to the assessment takers not able to complete the behavioral or cognitive assessment. Assessment takers will not receive a completion email. This incident is also affecting ability to send a Report Kit. We’ll post updates as soon as they occur. Thank you for your patience, and we apologize for the inconvenience.
Posted Feb 23, 2022 - 20:14 EST
This incident affected: PI Software: Assessment Site and API - Application Integrations.