This incident has been resolved. Software is operational at this time.
Posted Oct 29, 2025 - 23:57 EDT
Monitoring
Azure has implemented a fix to resolve the issue. The system is loading, however the software performance is still sporadic. We are still waiting for all systems to return to full operational status.
Posted Oct 29, 2025 - 19:20 EDT
Investigating
Microsoft is experiencing an unprecedented worldwide outage of its Azure data centers. These data centers host approximately 25% of all internet business applications, including The Predictive Index. Please know that any inability to access The Predictive Index is due to this event. We’re uncertain how long Microsoft data centers will be down, but we will let you know as soon as a resolution has been reached or an update is provided.
Posted Oct 29, 2025 - 12:48 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.