New Client Software Account Creation Failing
Incident Report for The Predictive Index
Resolved
Our engineering team has rolled out a fix for new client account creation failing and we can confirm that the issue is now resolved. We will now work through any failed requests during the incident period and reprocess those so that they complete.

Thank you for your patience while we worked through this issue., If you continue to encounter it, please let us know at customerservice@predictiveindex.com.
Posted Jun 24, 2021 - 08:55 EDT
Investigating
We're investigating an issue related to new account creation failing within Force BC/Salesforce. We do not believe that the account requests have been lost at this time, instead that we will only need to reprocess the requests once the issue is resolved.

This issue is also affecting BA Consent, where partners will receive an error message at the top of Force BC when clicking to generate a consent link.

We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Jun 23, 2021 - 17:08 EDT
This incident affected: Force BC.