Degraded PI Software Performance
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that this issue is now resolved. Thank you for your patience during our work on this.

If you continue to encounter problems logging on to the software or accessing modules, please let us know at customerservice@predictiveindex.com
Posted Dec 17, 2021 - 15:35 EST
Update
Our engineering team has implemented a fix that has brought our core platform, modules, and assessment site back up to full availability.

We will continue to monitor the situation and will set this incident to resolved after a period of time.
Posted Dec 17, 2021 - 14:47 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 16, 2021 - 20:13 EST
Monitoring
Our engineering team has isolated the issue and taken measures to bring our services back online. We have seen significant improvement in our availability although users may still experience errors as they work within our platform.

We will continue to monitor over the next several hours and will update this page as necessary.

Thanks so much for your patience and understanding.
Posted Dec 16, 2021 - 20:10 EST
Update
We are continuing our efforts to identify and resolve the issues affecting our core PI platform, our modules, and our assessment site.

Thank you for your patience and we will share updates here as we have them.
Posted Dec 16, 2021 - 19:43 EST
Update
Our engineering team is still working to restore service to our core platform, modules, and assessment site.

Thank you for your patience and we will share updates here as they occur.
Posted Dec 16, 2021 - 18:02 EST
Update
Our engineering team is still working to restore service to our core platform, modules, and assessment site.

Thank you for your patience and we will share updates here as they occur.
Posted Dec 16, 2021 - 16:31 EST
Investigating
Our engineering team is now investigating a secondary incident that is affecting all PI services. This includes all of our software modules as well as our assessment site, which are currently down.

We will provide further updates here as we work to bring our services back online.
Posted Dec 16, 2021 - 15:23 EST
Update
We are continuing to monitor the status of our authentication provider.

Thank you for your patience and we will share updates here as they occur.
Posted Dec 16, 2021 - 14:32 EST
Identified
Our external authentication service is experiencing an outage, causing users to be unable to log into the PI Software at this time.

Partners - please let your clients know that any inability to access The Predictive Index is due to this event. We’re uncertain how long the external outage will persist, but we will continue to provide updates here as more information becomes available. If you have a product demo scheduled for today, please consider rescheduling it proactively.

Thank you for your patience while we wait to receive updates from our external authentication service.
Posted Dec 16, 2021 - 13:37 EST