Degraded performance in the PI software

Incident Report for The Predictive Index

Resolved

Microsoft Azure have implemented a fix to resolve the issues and performance has been restored.
Posted May 13, 2025 - 20:11 EDT

Monitoring

There has been reports of degraded performance and inaccessibility within the PI software. Our teams have identified there is a slight Microsoft Azure outage that may be affecting the PI software application and will be continuing to monitor the situation.
Posted May 13, 2025 - 16:41 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.