Assessments Stuck Processing or Pending in Database
Incident Report for The Predictive Index
Postmortem

Yesterday, September 8, we experienced an issue with PI’s behavioral assessment results not being sent out upon assessment completion.This happened because of a PI software issue stemming from an overload in BAs being sent out. This caused delays in receiving assessment results up to 10 hours.

What we did:
Our engineering team has corrected the software issue and the delay has been fixed. Any assessment takers who completed a BA during this time have been sent their results.While you and your clients may not have been directly affected by this, the issue may have caused a slower response to any support requests in the last 24 hours. We are currently working through the built up case load and appreciate your patience and understanding.

Posted Sep 09, 2020 - 12:32 EDT

Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 12:30 EDT
Investigating
We are currently investigating an issue where assessments taken via open invitation link or email invitation are stuck in the database as either 'Processing' or 'Pending' and are not showing up in the software. We will update here as we receive more information. Thanks so much for your patience and understanding.
Posted Sep 08, 2020 - 14:40 EDT
This incident affected: PI Software: Core Platform.