Force Business Center/Salesforce Outage
Incident Report for The Predictive Index
Resolved
Salesforce has successfully restored service to our pod and our Partner Network should have full access to Force Business Center at this time. New user and new team creation within the software has also been restored and should now function normally.

Thank you so much for your patience and if you continue to run into any of the previously described issues, please email us at customerservice@predictiveindex.com
Posted May 11, 2021 - 21:38 EDT
Update
Salesforce has identified the root cause of their unprecedented global outage and are currently working to restore service on a pod by pod basis. Unfortunately we do not have an estimated time that our affected pod will be back online but will continue to monitor and will update here once the issue is resolved.

Thank you for your understanding and we appreciate your patience.
Posted May 11, 2021 - 20:55 EDT
Identified
Salesforce, which services our Force Business Center platform for our Partner Network is currently experiencing an outage. Due to this outage, Partners are unable to log in and any notifications or emails generated by Force Business Center will not be sent.

Software users will also not be able to create or edit any user records from within the PI software.

Because our User Operations team utilizes Salesforce for our ticketing queue, live chat, and phones, we are also unable to see or respond to any incoming tickets, chats, or phone calls at the moment.

We are closely monitoring the situation and will provide updates here as we receive more information. Thank you so much for your patience.
Posted May 11, 2021 - 17:52 EDT
This incident affected: PI Software: Core Platform and Force BC.