PI Diagnose Maintenance
Incident Report for The Predictive Index
Resolved
Maintenance to Diagnose has been completed. Thank you for your patience during this time.
Posted Oct 16, 2021 - 15:00 EDT
Monitoring
On October 16th from 11 AM - 3 PM EST, we'll be performing maintenance on PI Diagnose. Users will not be able to schedule, close, or take a survey during this time. We apologize for any inconvenience this may cause.
Posted Oct 15, 2021 - 16:43 EDT
This incident affected: PI Software: Core Platform and PI Software: Assessment Site.