Phone Support Down
Incident Report for The Predictive Index
Resolved
The issue with our phone service provider has been resolved and we are now able to take support phone calls. If you previously called in and left a voicemail or requested a callback, we will get to those in the order they were received.

Thanks so much for your patience.
Posted Mar 25, 2021 - 10:42 EDT
Investigating
Five9, our phone support provider, is currently working through an issue affecting a large portion of their clients. At this time we are not able to accept phone calls for support.

We will continue monitoring this situation and will be back on to handle your calls as soon as it's resolved.

If you need assistance in the interim, please email us at customerservice@predictiveindex.com.
Posted Mar 25, 2021 - 09:32 EDT