Logging In/Company Search
Incident Report for The Predictive Index
Resolved
We’ve confirmed that this issue has been resolved. Thank you for your patience while we worked through this issue., If you continue to encounter it, please let us know at customerservice@predictiveindex.com. A Postmortem will be shared within five business days of issue closure.
Posted Feb 11, 2021 - 15:09 EST
Update
We are continuing to investigate this issue.
Posted Feb 11, 2021 - 15:07 EST
Investigating
We're investigating an issue related to logging into the PI software platform and not being able to change companies. Affected users will encounter a blank white screen. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Feb 11, 2021 - 13:46 EST
This incident affected: PI Software: Core Platform.