PI Software - Diagnose - Intermittent Errors when Trying to Access the XP Survey Link
Incident Report for The Predictive Index
Resolved
Survey Monkey has confirmed that the issues have been resolved and services function as normal.
Posted Jan 31, 2023 - 14:21 EST
Identified
Survey Monkey which hosts our XP Survey is currently experiencing an issues across their platform causing errors and slow performance.

Any inability to access the XP Survey is due to this event. We’re uncertain how long it will take until Survey Monkey's services are fully restored. We will monitor the situation and will share updates here as they occur.
Posted Jan 31, 2023 - 13:04 EST
This incident affected: PI Software: Core Platform.