Team Discovery
Incident Report for The Predictive Index
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 12:56 EDT
Update
We’ve confirmed that this issue has been resolved. Thank you for your patience while we worked through this issue. If you continue to encounter it, please let us know at customerservice@predictiveindex.com.
Posted Oct 28, 2020 - 12:50 EDT
Investigating
We're investigating an issue related to the Team Discovery page not loading in the PI software. Affected users will encounter an error at the bottom of the page. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Oct 28, 2020 - 12:13 EDT
This incident affected: PI Software: Core Platform.