Unable to Access Person Page for Hire-only Subscription Accounts
Incident Report for The Predictive Index
Resolved
Our engineering team has confirmed that this issue has been resolved. Thank you for your patience while we worked through this issue. If you continue to encounter it, please let us know at customerservice@predictiveindex.com. A Postmortem will be shared within five business days of issue closure.
Posted Dec 02, 2021 - 12:15 EST
Investigating
We're currently investigating an issue related to the person pages not loading within the PI software. This issue only affects clients who are on a Hire-only subscription. Affected clients will be brought back to their main dashboard when clicking to open a person page.

We will post updates here as we have them. Thank you for your patience.
Posted Dec 02, 2021 - 10:18 EST
This incident affected: PI Software: Core Platform.