PI Software Access/Usage Currently Down
Incident Report for The Predictive Index
Resolved
This incident has been resolved. Thank you for your patience while we worked on this issue.
Posted Nov 03, 2021 - 17:38 EDT
Monitoring
We have released a fix for this issue, and are monitoring the results system-wide. Please refresh your browser, and if you continue to experience this issue, please contact customerservice@predictiveindex.com.
Posted Nov 03, 2021 - 16:45 EDT
Investigating
We're investigating an issue related to the PI software not loading when you are in the software or attempting to log into the PI software. Affected users will encounter a blank white screen. We are investigating the cause of this issue. We’ll post updates as we have them. Thank you for your patience, and we apologize for the inconvenience.
Posted Nov 03, 2021 - 16:30 EDT
This incident affected: PI Software: Core Platform.