PI Software Log in Issues
Incident Report for The Predictive Index
Resolved
Our teams have been able fully resolve this critical outage. If you continue to experience issues logging into the PI Software, please reach out to PI Customer Service at customerservice@predictiveindex.com. Thank you for your patience while our teams worked toward a resolution.
Posted Dec 29, 2020 - 20:38 EST
Identified
The issue has been identified and our teams are implementing a fix. We will update this page as soon as we have implemented the fix.
Posted Dec 29, 2020 - 20:26 EST
Investigating
Our engineering team is currently investigating an issue where certain users are unable to log in to the software. Those affected will receive a blank screen after inputting their credentials. We will provide updates to this page during the troubleshooting process and thank you for your understanding and patience while we work to resolve this problem.
Posted Dec 29, 2020 - 18:10 EST
This incident affected: PI Software: Core Platform.